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Worksheet I 
Introduction 
 

The exercises set out below illustrate some of the major techniques and principles of digital 
image processing and analysis.  They provide an opportunity to apply these to a range of 
images and to investigate and compare the results obtained. The exercises are based upon a 
software package NIH Image, originally developed for Macintosh computers by staff at the 
U.S. National Institute of Health.  This has been adapted for IBM PC compatibles by Scion 
Corporation, from whose WWW site the Scion Image PC package may currently be obtained 
free of charge, either for MS Windows 95 or NT 4.  Although the package is quite powerful, 
there are a few areas in which unexpected behaviour is observed. 
 

The approach used in the exercises is one of ‘learning by doing’.  Demonstrators will be on 
hand to assist, and will be happy to advise where difficulties arise.  For those who wish to find 
out more about Scion Image’s features, a User’s Reference is provided on-line  - Start > 
Programs > Scion Image > Scion Image Manual (.PDF).  A printed copy will also be 
available.  

Getting started 
 

� Enter Scion Image by using the mouse to give the command:  
Start > Programs > Scion Image > Scion Image. 

� Note that when it starts up the program creates the following windows on the 
screen by default:- 

 

� Menu bar 
� Information window 
� LUT (Look-up Table) menu 
� Tools menu 

 

� Using the mouse, explore each of the options provided in Scion Image’s pull-
down menus.  To do this, left click on the File menu; then, with the left button 
held down, drag the mouse from left to right along the list of menus.  Note 
particularly the Help > Contents option, which you can access at any later stage 
if you need fuller details of any of commands you may use subsequently. 

 

� Give the command: Special > Make Horizontal Grey Scale, and observe that a 
new image Horizontal Grey Scale is generated in which there is a steady 
gradation of displayed grey levels from left to right.  The command that generated 
the grey scale is not in fact a native Scion Image command, but is a sequence 
commands assembled as a macro.  The macro is a powerful technique for 
encapsulating complex or frequently-used sequences of low-level commands in a 
convenient form, and you will see other examples in these exercises.  

 

� Move the mouse so the pointer is over the new image; observe the information 
displayed in the Info window.  Note how this information is updated as the pointer 
(displayed as a cross-wire) moves around over the image. 

 

a) What grey levels correspond to the brightest and darkest parts1 of the image?   
b) Determine the X-coordinates of those columns of pixels having grey levels 

lying between 50 and 70 (inclusive);  
 
1Note.  The convention used in Scion Image to represent grey -levels is slightly unusual, but it can be changed 
using the command: Options > Preferences to enable the Invert Pixel Values option. 
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1 Grey Level Histogram and Look-up Tables 
 

1.1 Using the cursor 
 

� With the image Horizontal Grey Scale activated, create a grey-level histogram of 
the image using: Analyze > Show Histogram (Ctrl+H).  The histogram appears 
in a dedicated window of its own, and since with this basic command, no axes or 
labels are provided, it may be a little difficult to interpret. 

 

� Using the mouse, place the cross-wire cursor in the Histogram window and 
slowly traverse it across the body of the histogram; observe the Info window.  The 
labels: Level and Count indicate the number (count) of pixels at the 
corresponding level. 

 

� Determine, using the cross-wire cursor (in the Histogram window menu) the total 
number of pixels at each grey level (dimensions of image are 256 x 256 pixels). 

 

� (Optional) Experiment with the macro: Special > Plot Histogram using bins.  
Try different numbers of bins.  Notice that this macro provides axes and labels, 
but is typically slower to execute. 

 

1.2  Using the Intensity Profile 
 

� Generate the intensity profile along a horizontal line in the Horizontal Grey 
Scale image.  The command required to achieve this is Analyze > Plot Profile 
(Ctrl+K).  However, Scion Image requires you to select first the part of the image 
from which the profile comes.  Click once on Rectangular Selection Tool 
(rectangle at top right in the Tools menu), and move the cursor to the Horizontal 
Grey Scale image.  Pressing the left mouse button, drag out a rectangle stretching 
the full width of the image, release the button and give the Plot Profile command.   

Tip: you can use the Straight Line Selection tool from the Tools menu to define the 
track for the profile in any arbitrary direction. 

 

� Use the Edit > Invert command to invert the value of every pixel in the 
Horizontal Greyscale Image.  Create a further intensity profile along a 
horizontal line, and compare it with the previous profile; verify that it takes the 
form you expect. 

 
1.3  Reading an image from disk 
 

� Give the File > Open command, and select the file: Clay.tif.  The image will be 
read in and displayed in a new window. 

 

� Using the histogramming and profiling commands described above, try to 
determine the grey-scale range in the Clay.tif image.  What are the maximum and 
minimum grey level values? 

 

� Tip: to view all the images held in a folder on disk, navigate to that folder, select 
a single image with the mouse, check the Open All box and click OK. (This 
technique has been found to be unreliable if there are other kinds of file present in 
the folder). 
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1.4  Using Look-up Tables (LUTs) 
 

As described in lectures, LUTs are used to vary the correspondence between the each 
pixel value and the brightness (or colour) by which the pixel is represented on the 
display.  In Scion Image, both monochrome and pseudo-colour LUTs are available, 
and different kinds may be accessed via the Options menu.  The Map window is 
provided to facilitate adjustments to an existing LUT (e.g. for contrast stretch). 
 

� With the Horizontal Grey Scale image activated (if necessary, click the mouse 
within it), bring the cursor over the Map window.  This contains a small graphical 
representation of the relationship between pixel values and colour/brightness.  
Observing the Horizontal Grey Scale image, click on the centre of the plot; with 
the mouse button held down, drag to move the plot.  Note the effect on the plot, 
and on the B (brightness) and C (contrast) sliders below. 

 

� Experiment with the B and C sliders by clicking and dragging with the mouse.   
 

� Investigate the effect of clicking on the two tiny plots at the foot of the Map 
window.  What purpose might these serve?  (Discuss with a demonstrator if you 
are unsure). 

 

� It is worth noting that the operations just carried out do not affect stored pixel 
values.  Verify this by generating a histogram or line profile (see above). 

 

� Scion Image provides the command: Process > Apply LUT.  This command 
applies the mapping defined by the current LUT to each pixel, actually changing 
the grey level stored.  It then restores the LUT to a default law, so that the display 
will be seen to remain unchanged.  However, a histogram or profile will show that 
the pixel values have truly changed.  You can undo these changes by using the 
command: Edit > Undo.  In certain circumstances (e.g. if you have updated the 
image more than once) you may find that Undo fails to work as expected.  In such 
cases try the command:  File > Revert to Saved, which effectively re-reads the 
image from the data stored on disk, or use File > Open to obtain a fresh copy. 

 

� Use the Options > Color Tables to select one of the available pseudo-colour 
LUTs.  Note that pixel grey levels are now depicted as discrete colour 
combinations.  Investigate other colour tables if time permits.  Note that Apply 
Look-up Table is not available under these circumstances.. 

 

� Activate the image Clay.tif, (by clicking it with the mouse); repeat the operations 
just described with the monochrome and colour LUTs.  Note that by use of colour 
LUTs, subtle variations in grey level can be represented as much more 
conspicuous changes in colour.  Can you identify any disadvantages or problems 
arising from the use of pseudo-colour? 

 

� Scion Image tries to maintain separate LUTs for each of the images on the screen, 
although this becomes increasingly difficult as more and more images are opened 
or captured.  Scion Image provides a feature: Options > Propagate > Look-up 
Table, which applies a chosen look-up table to all other images being displayed. 
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2  More on Point Operations 
 

2.1  Reading images from disk 
 

� Open the SEM image Clay.tif (File > Open).  
� Create a grey level histogram and use it to determine the grey-scale (the range of 
grey levels) occupied by the image.  Make a note of the maximum (zmax) and 
minimum (zmin) grey level values. 
 
2.2  Contrast stretch operations 
 

� Using only the operations Process > Arithmetic > Subtract and Process > 
Arithmetic > Multiply, attempt to effect the maximum possible enhancement of 
contrast in the image Clay.tif. 

 
a) In which order should these operations be applied? 
 

b) Determine the numerical constants which, when used with these operations, 
bring about maximum contrast enhancement.  Read in a second copy of the 
image Clay.tif (File > Open), and compare the original with your contrast 
enhanced version.  Keep the second, unprocessed version available for exercise 
2.3. 

 

c) Write down the general algebraic expression in terms of zmax and zmin, for this 
grey-scale transformation relating the grey levels (z2) in the new image to those 
in the old image (z1). 

 
z2 = 

 
2.3  Contrast enhancement using the LUT 
 

� With the greyscale LUT activated, use the LUT manipulation facilities available 
in the Map window in an empirical way to achieve the greatest possible perceived 
contrast.  Use Process > Apply LUT to apply the transformation to the image 
itself, and generate a histogram of the result.  Compare the result achieved with 
the original image, and with the result of exercise 2.2.   

 
2.4  Histogram equalisation using the LUT 
 

� Obtain a further copy of the unprocessed image: Clay.tif.  Use the command: 
Process > Equalise to perform grey-level histogram equalisation on the image.  
Note the appearance of the modified LUT profile.  Apply the transformation to the 
image, generate the grey-level histogram, and compare the results achieved with 
exercises 2.1 and 2.2. 

 

� Comment on the three techniques for contrast enhancement in terms of: 
 

a) ease of use; 
 

b) subjective appearance of the two images. 



RMS Digital Image Processing Workshop Practical Session 

Introduction to digital image processing & analysis  - 5 - D M Holburn 15 March 06 

2.5  Contrast enhancement with noisy images (if time permits) 
 

� Obtain a fresh copy of the image Clay.tif.  Use the macro command: Special > 
Inject Salt & Pepper noise to simulate a ‘noisy’ image.  Note: this macro takes 
some seconds to run.  Create a grey-level histogram and determine the new 
maximum and minimum grey levels present. 

 

� How must the method of section 2.1 be modified in the light of these values, and 
what are the new numerical constants needed? 

 

� Now repeat the procedures of sections 2.2 and 2.3.  Which of these techniques is 
the most effective in enhancing contrast in the presence of  noise? 
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Worksheet II 
3  Neighbourhood (local) operations & spatial filters 
 

Scion Image provides a simple method of implementing arbitrary spatial filter kernels 
up to 63 x 63.  Each kernel is specified by means of a text file – for example 
LowPass3x3.txt.  Scion Image provides a basic text editor to allow kernels to be 
created or edited directly. 
 

� Use the File > Open command to open one or more of the filter kernels provided 
in the Filters folder, and try to reconcile the displayed values   

 

3.1  Low-pass and high-pass filters 
 

� Open a copy of image Froad.tif.  Although this image has little to do with 
microscopy, it is useful in the present context because it is an easily recognisable 
scene, and contains a number of ‘typical’ image features.  Explore the effect of the 
following convolution filter kernels, and observe their effect.  You may wish to 
make a number of copies of Froad.tif using File > Duplicate, since the 
convolution result overwrites the original image: 

 
♦ LPmild.txt (Low-pass - mild), and LPsevere.txt (Low-pass - severe) 
♦ Hpiso.txt (High-pass - isotropic) 
♦ HPUnsharp.txt (Unsharp-mask) 
♦ HPLaplacian.txt  (High-pass: laplacian) 

 

Note that certain of the hard-coded filters provided in Scion Image (e.g. Process > 
Smooth, Process > Sharpen) resemble those listed above.  If time permits, 
investigate these. 
 

3.2  Using low-pass filters on noisy images 
 

� Inject noise into a copy of image Froad.tif (Special > Inject Salt & Pepper 
noise).  You may wish to make a number of copies using File > Duplicate since 
subsequent operations will overwrite the source image. 

 

� Experiment with the effects of LPmild.txt and LPsevere.txt, both of which are 
low-pass filters, on the resultant noisy image.   What happens to the noise spikes? 

 

� Creating a new copy of the noisy image if necessary, explore the effects of 
HPUnsharp.txt, and, if time permits, other high-pass filter kernels.  Note any 
effect on the noise spikes. 
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3.3  Median filter with noisy images 
 

� Inject noise into a copy of image Froad.tif and try the effects of the 3 x 3 median 
filter for reducing noise. This is provided via menu command: Process > Rank 
Filters … and select the Median Filter option.  Note that this command overwrites 
the original image. 

 
3.4  Setting up your own filter kernels. 
 

� Use the File > New command (select Text Window in the resulting dialogue box) 
to create a text window, and set up the two Sobel edge detectors; use File > Save 
to save each result as a text file; choose appropriate names of your own for them.  
The required values are shown below. 

 
-1 0 +1  +1 +2 +1 
-2 0 +2  0 0 0 
-1 0 +1  -1 -2 -1 

 
� Determine the effect of each filter on a copy of the image Froad.tif (without 

injected noise), and on any others of particular interest to you. 
 
 



RMS Digital Image Processing Workshop Practical Session 

Introduction to digital image processing & analysis  - 8 - D M Holburn 15 March 06 

Worksheet III 
4 Image Segmentation and Thresholding 
 

4.1  Determining characteristic grey levels 
 

Njaws.tif is a low-magnification dental X-ray, and is a negative – light areas (low 
grey levels) correspond to features of high optical density; darker regions (high grey 
levels) represent features of lower optical density (e.g. soft tissue, voids).  Dentine 
(the interior of the teeth) is represented by intermediate values.  This is a convenient 
image to demonstrate segmentation techniques (as well as image analysis). 
 

� Obtain a copy of the image Njaws.tif.  Using the cursor and the Information 
window, determine the average grey levels corresponding to:- 

 

(a) amalgam fillings; 
(b) soft tissue; 
(c) dentine; 
(d) voids 

 
4.2 Thresholding the image 
 

In this section we shall explore how practical it is to use simple thresholding to 
distinguish key features in the original greyscale images 
 

� With the Njaws.tif image active, select the Thresholding mode of operation, by 
giving the command: Options > Threshold.   

 

� Bring the cursor into the LUT window – a vertical double-headed arrow should 
appear.  Gradually move the threshold level (the transition between black & white 
in the LUT window) until the level (shown in the Information window 
corresponds to the value you determined for amalgam fillings.   

 

Note that in making these adjustments you are not affecting the stored image, but are 
simply varying a LUT profile (see the Map window). 
 

� Study the image, and adjust the threshold to give the most satisfactory 
segmentation for amalgam fillings. 

 

� Is the same technique applicable for segmentation of dentine, soft tissue and 
voids?  What problems arise with these features of intermediate grey level? 

 

� Can you devise a suitable set of arithmetic operations (for example, subtract, 
multiply) to assist in this?  If time permits, implement your arithmetic solution, 
and briefly document your chosen procedure. 
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4.3 A more advanced technique based on density slicing 
 

Segmentation of features at intermediate grey-levels is inconvenient with a single 
thresholding operation.  If an upper and lower threshold may simultaneously be 
applied, a range of otherwise tricky segmentation operations can be accomplished.  In 
Scion Image, this can be achieved by means of the program’s Density Slicing mode. 
 

� Give the command: Options > Density Slice.  This invokes a special form of 
thresholding LUT with independently adjustable upper and lower thresholds.  You 
can alter the upper and lower thresholds in the LUT window (just as with the 
single threshold) by ‘grabbing’ the chosen threshold with the double-headed 
arrow and dragging it up and down by means of the mouse.  As you do so, the 
upper and lower thresholds are displayed in the Information window.  In the 
active image, pixels with grey levels lying between the thresholds are coded red; 
those outside the range defined by the threshold are displayed unchanged. 

 

� Adjust the upper and lower thresholds experimentally to obtain in turn the most 
satisfactory thresholding of amalgam filling, dentine, soft tissue and voids; note 
the thresholds.   

 
Once again, this procedure does not affect the stored image since it is accomplished 
by means of LUT manipulations.  You can convert the thresholded or density-sliced 
image into a binary image (comprising pixels of only two values: 0 and 1, or not-
object and object) by means of the command: Process > Binary > Make Binary; or 
alternatively: Process > Apply LUT.  If density slicing is active, a dialogue box 
appears to confirm how you wish the highlighted pixels to be displayed.  You should 
set the options so that highlighted pixels are converted to foreground or object, and 
the remaining pixels are converted to background (not-object). 
 

4.4  Edge image 
 

In this section we shall demonstrate the principles of another class of techniques for 
segmentation based on edge detection. 
 

� Obtain a further copy of the image Njaws.tif 
 

� Carry out the command: Process > Find Edges, and observe how the fringes of 
the amalgam, voids, etc are highlighted by this process.  The Find Edges 
command is based on the Sobel edge detector mentioned in lectures, and is a form 
of high-pass filter.  Try and assess the extent to which edges in every direction are 
clearly distinguished by the procedure. 

 

� If time permits, experiment with other forms of high-pass filter (available under 
the Process and Process > Convolve menus, as well as by means of some of the 
macros supplied under the Special menu. 

 



RMS Digital Image Processing Workshop Practical Session 

Introduction to digital image processing & analysis  - 10 - D M Holburn 15 March 06 

5 Segmentation and Analysis 
 

5.1  Segmentation in action 
 

� Obtain a copy of the image: Astro.tif 
 

� Use the techniques introduced in sections 4.1 – 4.4 (Threshold and/or Density 
Slice modes) to determine the most effective threshold(s) for segmentation.  
Convert the segmented image into a true binary image. 

 

5.2  Analysis of a binary image 
 

A binary image is one in which the pixels can assume only two different values: 
WHITE and BLACK (or OBJECT and BACKGROUND).  Such images can be 
produced by use of segmentation and related techniques.  This section makes use of 
utilities in Scion Image to indicate some of the techniques available for analysing and 
editing binary images. 
 

� Obtain a copy of the binary image: Nuts.tif, which has been derived from a 
greyscale image of some familiar engineering artefacts.  In this case the objects of 
interest are represented by bright pixels (rather than dark as conventionally used 
by Scion Image to signify objects). 

 

� Try to find a suitable Scion Image procedure to convert this image into binary 
form, with nuts, bolts etc represented as dark pixels.  If you are unsure how to 
proceed, discuss with a demonstrator.  You will need this binary image for the 
next section. 

 

5.3  Detecting objects 
 

In this section we shall explore Scion Image’s facilities for analysing binary images 
and extracting useful measurement from fields of objects. 
 

� With the appropriate binary form of Nuts.tif (see previous section) activated, use 
the command: Analyze > Analyze Particles to detect and measure objects in the 
image.  When the dialogue box appears, check that Minimum Particle Size and 
Maximum Particle Size are set to 1 and 999999 respectively; and make sure that 
the following boxes are checked:- 

Label particles 
Reset Measurement Counter 

� The remaining boxes should be unchecked.  OK the box to proceed with analysis. 
 

Each detected object should appear shaded grey, and should be annotated with an ID 
number, (used to help to reconcile measurements with displayed objects).   
 

� Use the command: Analyze > Show Results to display the information so far 
accumulated about each object (Results window). 

 

� How many objects are detected?  Does this agree with your visual inspection? 
 

You will notice that in certain cases pairs of objects are in physical contact, and 
actually appear as single objects after the segmentation process.  Touching objects 
can be a source of difficulty in automated image analysis. 
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5.4  Exploring the table of information 
 

In this section we shall investigate the some of the measurements carried out by Scion 
Image on a binary image. 
 

� Use the scroll bars to scroll up/down or left/right through the data in the Results 
window; if you prefer, resize the window to give a more convenient display.  
Study the quantitative information displayed.  Is this information consistent with 
your own visual impressions? 

 

By default, Scion Image determines the area of each object; however, the package can 
calculate in excess of ten different quantities for each object.   
 

� In order to display this additional information it is first necessary to enable each 
feature required, using the Measurement Options dialogue box generated in 
response to the command: Analyse > Options.  Examine the options available, 
and try to decide which parameter (or combinations of parameters) might be of 
greatest help in automatically discriminating between objects of different types 
within the field.   
Note: after changing the Measurement Options it is necessary to repeat the 
Analyze > Analyze Particles command and the Analyze > Display Results 
commands in order to see the effect.  When you carry out analysis a second or 
third time you will need to OK a warning dialogue informing you that earlier 
measurements will be lost if you proceed. 

 

5.5  Calibration and real dimensions 
 

Scion Image measures objects by counting pixels.  Hence, by default, the results are 
shown in units of pixels (or square pixels, etc).  The size of each pixel depends not 
only on the physical dimensions of the specimen being measured, but also on the 
instrumental magnification, capture parameters, and any geometric processing that 
may have been applied to the image.  In order for measured values to be of use, they 
need to be expressed in real units, e.g. nanometres, inches.  This can be accomplished 
by means of a calibration procedure, in which a scaling factor is applied to convert 
measurements in pixels to meaningful values.  Scion Image provides the command: 
Analyze > Set Scale … for this purpose.  This offers a dialogue box in which a 
reference measurement (some known feature measurement) and the name of a 
convenient measurement unit can be entered, plus the corresponding on-screen 
dimension given in pixels.  This last parameter can be determined either by noting the 
cursor coordinates of the feature extremities and taking the difference, or, more 
simply, by using the Straight Line Selection tool. 
 

To calibrate the measurements, proceed as follows. 
 

� Use the Magnify Glass tool to give a conveniently magnified view of the 
reference feature; left-click the mouse over the feature of interest to increase 
magnification; press the Ctrl key and left-click to revert to original magnification. 

 

� Click on the Straight Line Selection tool, and bring the cursor to one edge of the 
reference; click and hold down the left button while dragging the cursor to the 
other edge; release the button when the cursor exactly coincides with the opposite 
edge.  A ‘marching-ants’ line should be seen superimposed on the object. 
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� Double click on the Straight Line Selection tool to bring up the Set Scale 
dialogue box; you should see the measurement you just took (in pixels) displayed 
in the Measured Distance field.  Select the preferred units using the Units drop-
down menu, and enter the reference dimension in the Known Distance field.  
Leave Aspect Ratio set to 1.000, and OK the dialogue box. 

 

As a result of this procedure, measurements displayed from this point on will be 
shown in the selected system of units.  Naturally, the accuracy achieved depends on 
the care with which the measurement is taken; however, it is very important to 
remember that despite the fact that numbers can now be displayed to many decimal 
places, the best accuracy obtainable can be no better than about one pixel.  If you are 
unclear about this point, discuss it with a demonstrator. 
 

� In this instance the largest circular washer (object 13, at lower centre) in the Nuts 
image has outside diameter 18.0 mm.  Using the procedure just described, 
determine the Area and Perimeter in millimetres of objects 1, 2 and 3.    

 

5.6  Identifying objects 
 

Image analysis is sometimes regarded as one of the preliminary (or low level) stages 
of machine vision, in which a computer inspects a scene, recognising the components 
of which it is constructed, and makes intelligent deductions, possibly responding to 
the information gathered by controlling a mechanism (as in industrial robotics or 
compuer-aided manufacture). 
 

� Consider how you might discriminate between, or recognise the following image 
features, based on the statistical measurement information available from Scion 
Image: 

  
(i)   bolts of different sizes; 
(ii)  nuts and bolts; 
(iii) springs and bolts; 
(iv) nuts and lockwashers (corrugated interior). 

 

5.7  Touching objects 
 

You have probably noticed that the Nuts image contains two touching objects (nuts 
comprising object 11) which are treated as a single object for the purposes of 
measurement.  Touching objects can cause particular difficulty in automated image 
analysis.  Scion Image provides a number of commands in the Process > Binary 
menu which can be useful in these circumstances.  Alternatively it is possible to 
separate objects manually by ‘painting’ or ‘drawing’ with background pixels.   
 

� If time permits, experiment on the thresholded (binary) version of Nuts.tif with 
the following Scion Image morphological commands: Erode, Dilate, Open and 
Close (all provided in the Process > Binary menu). 
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6.1  A Case Study - Segmentation and Analysis 
 

Section 5 served as an introduction to this section, which involves the use of a variety 
of commands in Scion Image’s menus for processing and analysis.  Full instructions 
are not given here, but the demonstrators will be pleased to help and advise you as 
you plan how to proceed. 
 

6.1  Segmentation and Analysis of an Astronomical Image 
 

� Obtain a copy of the astronomical image Astro.tif. 
 

� You may wish to consider using arithmetic operations to enhance contrast, and/or 
spatial or rank filters to smooth or moderate noise present in the image. 

 

� Produce a binary image of the field.  You should investigate which of the various 
approaches – e.g. thresholding or density slicing – gives the best result. Discuss 
any practical difficulties that arise. 

  

� Using the utilities in the Analyze menu, estimate the following:- 
 

(a)  the total number of objects in the field, 
(b)  the number of stars, 
(c)  the number of galaxies. 
 

� Try to estimate these numbers by visual inspection of the image, and compare 
with your computer analysis. 

 

6.2  Morphological operations 
 

� Try distinguishing stars from galaxies (in the binary image) using morphological 
commands from the Process > Binary menu. 
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Worksheet IV 
7  Fourier Transforms and Fourier Filtering 
 

7.1  Fourier Transforms of simple images 
 

Images S800.tif, S1600.tif, etc. all consist of simple sine-wave variations.  Since 
Fourier transforms express image or other data in terms of superposed sine or cosine 
functions, these images are expected to have Fourier transforms that are quite simple 
in form. 
 

� Read image S800.tif.   
 

� Use the Process > FFT > FFT command to perform the forward Fourier 
transform on the image S800.  Note that the original image is not affected.  A 
second image is generated, showing the frequency spectrum of S800.tif.  To make 
this more visible you are recommended to invert the contrast image of the 
spectrum; use Edit > Invert to do this 

 

� Note that the spectrum consists of a bright central spot, with two further bright 
points positioned symmetrically to left and right.  The central spot corresponds to 
'zero frequency', and relates to the average brightness of the original image. 

 

� Repeat the same operations, this time using image S1600.tif.  Perform the FFT 
and generate the spectrum.  Compare the two spectra you have generated from 
S800 and S1600, and try to determine any differences and why they have arisen. 

 

� Repeat the same set of operations, this time using image S845.tif, and generate its 
spectrum.  What are now the differences that can be observed?  Why have these 
arisen? 

 
7.2  Fourier transform and spectrum of natural images 
 

Natural images typically contain more complicated variations than do the simple 
sinusoidal images examined in section 7.1.  Consequently we expect their transforms 
and spectra to be more complicated in appearance. 
 

� Obtain a copy of the grey scale image Njaws.tif, which is a low-magnification 
dental X-ray image.  (You can repeat the operations described on further images if 
you wish). 

 
� Use the Process > FFT > FFT command to generate a spectrum of this image.  
 
You will probably observe little more than a bright central spot, with perhaps some 
slight evidence of further structure away from the centre.  The reason you cannot see 
the additional information referred to at the head of this section is because it is much 
smaller in amplitude compared with the 'zero-frequency' component represented by 
the central spot.  When the spectral data is linearly scaled, as here, for viewing with a 
grey scale of 256 levels, much of the 'interesting' variations are lost.  One way round 
this is to display the logarithm of the spectral data (or more usefully, log(1+data)). 
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� Try using the Process > FFT > Inverse FFT command to confirm that you are 
able to regenerate the original spatial image from the transform data, confirming 
that for most practical purposes, the Fourier Transform is reversible.  

 
 

Once you have reached this stage, you are ready to explore the vast potential of the 
Fourier Transform for filtering, reconstruction, and many other applications.  Several 
of these can be carried out effectively with NIH Image, and you are welcome to 
experiment with these.   
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