Those who have performed the 3C7 experiment should bring the write-up along to this laboratory

Objectives

- Show that the accuracy of finite element calculations depends on the choice of elements and the layout of the finite element mesh.
- Design suitable finite element meshes and apply appropriate boundary conditions.
- Demonstrate modelling, accuracy and sensitivity issues for finite element and experimental methods by comparing results with the analytical solution for a particular problem.

1. Background

1.1. Description of the finite element method

The finite method is a numerical technique based on discretising a structure into an assembly of elements. In each element the displacement field is approximated by a low order polynomial that expresses the displacement field as a function of the spatial coordinates. For example, the three-node triangular element shown in Figure 1 has at the nodes $i = 1, 2, 3$ the $x$ and $y$ components of the displacement $u_{xi}$ and $u_{yi}$, respectively. The displacement field in the interior of the element is assumed to vary linearly with $x$ and $y$ and is compatible along the common boundary between elements. In general terms the displacement field within the three-node triangular element can be written as

$$u_x = \alpha_1 + \alpha_2 x + \alpha_3 y,$$
$$u_y = \alpha_4 + \alpha_5 x + \alpha_6 y,$$

where $\alpha_i$ depend on the nodal displacements and coordinates. Hence the strains are given by

$$\epsilon_{xx} = \frac{\partial u_x}{\partial x} = \alpha_2,$$
$$\epsilon_{yy} = \frac{\partial u_y}{\partial y} = \alpha_6,$$
$$\gamma_{xy} = \frac{\partial u_x}{\partial y} + \frac{\partial u_y}{\partial x} = \alpha_3 + \alpha_5.$$

Thus, we see that the strains do not vary within an element and hence this element is called a ‘constant strain triangle’. Omitting tedious algebra, the strain field of the
Figure 1: A three-node triangular element with six degrees of freedom.

The simple linear displacement field can only approximate the actual displacement field; in general it constrains displacements and consequently the element is too stiff. An improved representation of the actual displacement field can be obtained by including more nodes in each element so that the displacement field in the element is given by a higher order polynomial; e.g. a six-node triangle with mid-side nodes between the corners has a quadratic displacement variation along each edge. Higher order elements give more accurate strains, so for the same number of nodes, it is generally more accurate to use a smaller number of high order elements rather than a larger number of low order elements. On the other hand, large size elements lack versatility in representing the physical shape of the body.

1.2. Choice of elements, mesh layout and boundary conditions

Commercially available finite element analysis programs provide a wide range of available elements. For example PTC Creo Simulate, the program which you will use, provides constant strain and many higher order triangular elements. The higher order elements have mid-side nodes so the user can specify curved rather than straight sides (this is possible by using isoparametric mappings). When constructing the mesh and applying boundary conditions to analyse a problem, it is important to keep the following guidelines in mind:

(i) Elements should be graded in size in inverse proportion to the stress gradient; i.e. small elements in regions of large stress gradient or where high accuracy is required.
(ii) Element aspect ratios (i.e. length/width) should be less than three and never
greater than five in order to limit numerical errors due to an ill-conditioned stiffness
matrix.

(iii) At a given node, displacement and/or force boundary conditions can be specified.
However, in a given direction on a given node we can only specify a force or a
displacement boundary condition.

(iv) For a symmetric body subjected to symmetric loading, only half of the body needs
to be modelled since displacements must be symmetrical about the line of symme-
try. For the FE model of half the body, the displacement of all nodes on the line of
symmetry must be constrained to be zero in the direction normal to the line. At
the same time, these nodes should be free to move parallel to the line.

(v) The model must provide sufficient displacement constraints to prevent rigid body
motion. Allowing rigid body motion is a mistake that will result in a singular
stiffness matrix (i.e. the inverse does not exist).

2. Task

This laboratory exercise involves performing finite element analyses of a tensioned strip
with a circular hole using various meshes. The quantity of interest is the stress field in
the strip. The analysis is performed using the PTC Creo family of computer aided engi-
neering software. Detailed instruction on using PTC Creo are provided in Appendix A.
Assess your results against experimental or semi-analytical results at the earliest possi-
bility to gain confidence that your model has been input correctly.

2.1. Centred hole analysis

Analyse a strip of width 100 mm, length 200 mm, thickness 1 mm and hole radius
$R = 14.8$ mm. The Young’s modulus is $E = 70$ GPa and the Poisson’s ratio is $\nu = 0.33$.
The strip is subjected to uniform tension of $\sigma_0 = 1$ N/mm$^2$ applied at its ends. Due to
symmetry, it is sufficient to model one quarter of the strip as shown in Figure 2.
Find the maximum von Mises and $\sigma_{xx}$ stresses and the minimum $\sigma_{yy}$ stress. Record your
results in the table given below. Create line plots of $\sigma_{xx}$ and $\sigma_{yy}$ along the $x$ and $y$ axes
in Figure 2 and plot contours of the von Mises stress. Obtain the stress distributions
using the following combination of elements and meshes:

(a) A uniform mesh of approximately 250 linear triangular elements, which should re-
semble the one shown in Figure 2. This mesh should have approximately 300 degrees
of freedom. Produce a colour plot of the von Mises stress and plots of the normal
stresses along the $x$ and $y$ axes of the strip. Record your results as ‘Run 1’ in the
table below.

(b) A uniform reference mesh of approximately 15000 quadratic triangular elements.
This mesh should have approximately 60000 degrees of freedom. Produce a colour
plot of the von Mises stress and plots of the normal stresses along the $x$ and $y$ axes
of the strip. Record your results as ‘Run 2’ in the table below.
Figure 2: Mesh with 259 linear triangles and 154 nodes. The maximum element size used was 8.

(c) A mesh with approximately 250 quadratic triangular elements. This mesh should have approximately 1100 degrees of freedom. Adjust the number of elements and their size distribution to create a graded mesh in-line with the advice given in Section 1. The objective is to obtain the greatest accuracy with the limited number elements. This will be by trial and error, record your iterations in the table below. Only for the analysis which gives the greatest accuracy produce the von Mises contour colour printout and the four line plots as before. Also produce a plot of the finite element mesh for this analysis.

<table>
<thead>
<tr>
<th>Run</th>
<th>Mesh Type</th>
<th>Polynom. order</th>
<th># Dof (target)</th>
<th># Dof (actual)</th>
<th>max Mises</th>
<th>max $\sigma_{xx}$</th>
<th>min $\sigma_{yy}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>uniform</td>
<td>linear</td>
<td>$\approx 300$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>uniform</td>
<td>quadratic</td>
<td>$\approx 60000$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>uniform</td>
<td>quadratic</td>
<td>$\approx 1100$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>graded</td>
<td>quadratic</td>
<td>$\approx 1100$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>graded</td>
<td>quadratic</td>
<td>$\approx 1100$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>graded</td>
<td>quadratic</td>
<td>$\approx 1100$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
2.2. Off-centre hole analysis

This section is optional for the standard laboratory. In the Laboratory Report, results from this analysis are not required. Students using this laboratory exercise for their Full Technical Report must do this analysis in full and discuss it in their report.

Using a very fine reference mesh with linear triangles and a mesh of quadratic triangles with no more than 600 degrees of freedom, analyse the a plate (thickness = 1mm) with an off-centre hole subjected to a uniform remote tension $\sigma_0 = 1 \text{N/mm}^2$. Set the distance of the hole centre from the centre-line to be $e = 16 \text{mm}$ and the radius of the hole again to be $R = 14.8 \text{mm}$. The material properties are the same as those used above. Begin by making a sketch of the boundary value problem to analyse (taking into account any symmetries) and then adjust the number of elements and their size distribution in-line with the advice given in Section 1 to obtain the greatest accuracy with these limited number of nodes. Plot the distributions of $\sigma_{xx}$ and $\sigma_{yy}$ along axes passing through the centre of the hole and parallel to the sides of the plate.

3. Writing up

You should refer to the advice given in the General Instructions document Sections 2.2 and 2.3.

3.1. The Laboratory Report [3 hours]

This report should be posted into the Post Box (opposite the Lift) on the Mezzanine Floor in the Inglis Building within 15 days of your lab session, latest at 4pm.

This should be word-processed and no more than three pages, excluding any diagrams and graphs. The report pertains only to the centred hole problem of Section 2 and should contain the following in addition to any other issues that you may wish to discuss.

- Along the $x$- and $y$-axis, plot the $\sigma_{xx}$ and $\sigma_{yy}$ distributions calculated with models (a), (b) and (c). Compare these stresses with those obtained for a hole in an infinite plate that is stretched uniformly and also compare the stress at the periphery of the hole with Howland’s analytical solution, see Appendix B.

- On the same graph plot the stresses calculated from strain gauge measurements taken in the 3C7 Lab. Those who have not done that lab may contact the Instructor for the results from the 3C7 Laboratory.

- Discuss reasons for any differences between the measured, analytical and finite element stresses and comment on the relative accuracies of the finite element models (a) and (b) and (c).

- Examining the von Mises stress contours indicates where yielding would first initiate in this strip. Estimate the applied stress $\sigma_0$ at which yielding initiates in a strip made from an Al-alloy (Yield strength of the Al-alloy is $\sigma_Y = 200 \text{MPa}$).

- Briefly discuss the finite element modelling approach used to analyse the problem.
3.2. The Full Technical Report [10 additional hours]

This report should be posted into the Post Box (opposite the Lift) on the Mezzanine Floor in the Inglis Building before the end of the term.

Guidance on the preparation of Full Technical Reports is provided in Appendix I of the General Instructions document and in the CUED booklet A Guide to Report Writing, with which you were issued in the first year. If you are submitting a Full Technical Report on this experiment, you will need to refer to the books indicated in the References section below. You should include your Laboratory report as an Appendix and refer to it as appropriate.

- Discuss the boundary conditions used to represent the off-centre hole problem. How was rigid body motion prevented in this problem?
- For the off-centre hole problem, plot the $\sigma_{xx}$ and $\sigma_{yy}$ distributions along axes passing through the centre of the hole and parallel to the sides of the plate. Compare these with the strain gauge measurements made in the 3C7 Lab. Those who have not done that lab may contact the Lecturer for the results from the 3C7 Laboratory.
- The off-centre hole problem has no known analytical solution. Given more time, how could you test the accuracy of your calculation of the stresses around the hole?
- The Rayleigh-Ritz process of approximation is frequently used in elastic analysis and is similar to the finite element method. Appealing to the Rayleigh-Ritz process or otherwise, explain why element selection and mesh design affects accuracy of finite element calculations.
- Integration over elements in commercial FE codes is usually done using Gauss quadrature, as discussed in the 3D7 lectures. Briefly discuss the choice of quadrature rules and explain how an ‘hourglass instability’ can occur with an incorrect choice of the order of integration.

References


F. Cirak
January 2015
A. Instructions for using PTC CREO to analyse the centred hole problem

A.1. General comments

Make sure your computer has booted into Windows. As the computer boots up don’t forget to type windows.

We first use PTC Creo Parametric for creating the geometry and then use PTC Creo Simulate for performing the analysis. The geometry and boundary conditions of the tensioned strip with a hole to be analysed are given in Figure 2.

Useful mouse button/keyboard combinations for view manipulation.
Spin: Hold down Middle Mouse Button and move the mouse.
Pan: Hold down Shift key + Middle Mouse Button and move the mouse.
Zoom: Scroll Middle Mouse Button.

A.2. Geometry input with PTC Creo Parametric

A.2.1. Setup

1. Start > All Programs > PTC Creo > Creo Parametric 3.0
2. File > New
   - Select Part as the Type and Sheetmetal as the Sub-type.
   - Enter a file name in the Name textbox.

![Image of software interface]

3. File > Prepare > Model Properties
   - Ensure Units are millimetre Newton Second (mmNs) and Thickness is 1.0.
A.2.2. Geometry Input

1. Click **Planar** and select a working plane by clicking on **FRONT** in the graphics window.

2. Click **Corner Rectangle** and sketch a rectangle in the graphics window.

3. Click **Center and Point** and sketch a circle (that will later represent the hole).

4. Press **Esc** key to display the dimensions of the input geometry in the graphics window.

   - Double-click on the displayed dimensions to set them to the desired values. (For this exercise use the geometry and boundary conditions shown in Figure 2.)

5. Click **Erase** then select the unwanted segments in the graphics window to erase them.

6. Click **Ok** to complete the Sketch.

7. Rotate the view of the created geometry using the middle mouse button and flip the normal by clicking on the displayed arrow.

8. Click to complete the Part.

9. Save and exit Creo Parametric 2.0.
A.3. Finite element analysis with PTC Creo Simulate

A.3.1. Setup

1. Start > All Programs > PTC Creo > Creo Simulate 3.0
2. File > Open
   • Open the geometry created previously with PTC Creo Parametric.
3. Ensure that Home > Structure Mode is selected.
4. View > Saved Orientations > FRONT
5. Home > Model Setup > Advanced
   • Select 2D Plane Stress
   • Click on Coordinate System box to activate and select CS0 from the Model Tree.
   • Click on the Surfaces box and select the plate displayed in the graphics window.

A.3.2. Loading

1. Home > Force/Moment
   • Click on right vertical edge and set the x-component to 50. (Note that this value is the total applied force in Newtons).

A.3.3. Boundary conditions

1. Home > Displacement
   • Click on the horizontal symmetry axis in the graphics window and in the Constraint window set the X Translation (displacement) to free and Y Translation to fixed.
• In the same way apply the boundary conditions for the vertical symmetry axis.

A.3.4. Materials

1. Home > Materials
   • Click File > New.
   • Set the material parameters as given in Section 2.1.
   • Click Save To Model.

2. Refine Model > Shell > Shell

   • Click on the plate displayed in the graphics window.
   • In the Shell Definition window set Thickness to 1.
   • Select the material created in the previous step.

A.3.5. Basic Meshing

1. Refine Model > Control > Maximum Element Size

   • Click on the plate displayed in the graphics window.
   • In the Maximum Element Size Control window set Element Size to 8.
     – Record the chosen Element Size for your write-up.

2. Refine Model > AutoGEM > Settings
   • In the AutoGEM Settings window, select Tri as the 2D Plate Element Type.
3. Refine Model > AutoGEM > AutoGEM

- In the AutoGEM window select **Surface** from the drop-down list.
- Click \( \square \) and select the plate displayed in the graphics window.
- In the AutoGEM window click **Create**.
- Close appearing message windows and when asked save the mesh.

Finally the mesh is created and the analysis will be carried out.

### A.3.6. Analysis

1. Home > Analyses and Studies

- In the Analyses and Design Studies window click **File** and then **New Static**.
- In the Static Analysis Definition window in the Convergence tab select **Multi-Pass Adaptive** as the Method.
- Set **Polynomial Order Minimum** and **Maximum** to 1.
  - Note that this means we are computing with only linear polynomials. For quadratic polynomials we would have to set the **Polynomial Order Minimum** and **Maximum** to 2.
- In the Analyses and Design Studies window click **Run > Start**.

- In the Analyses and Design Studies window select **Info Status..** to view analysis log file.
Record for your write-up the Total Number of Equations (i.e. DOF’s) and the stresses max\_stress\_vm (i.e. von Mises stress), max\_stress\_xx (i.e. max $\sigma_{xx}$) and max\_stress\_yy (note that this output value is really min $\sigma_{yy}$).

A.3.7. Post-processing

1. Plotting the von Mises stress over the domain.

   - In the Result Window Definition window select the stress component desired (von Mises).
   - In the Result Window Definition window select Displays Option tab and check Deformed and Show Element Edges.
   - In the Creo Simulate Results window select File > Print.
   - In the Print window select Unixflow from the Choose printer drop down menu.
   - In the Print window click Properties and in the Unixflow properties window select Color tab and choose Color Mode Auto [Color/B&W]

2. Plotting the normal stresses along the $x$ and $y$ axes of the strip

   - In the Result Window Definition window
     - As the Display type select Graph from the drop-down list.
     - Click the Quantity tab and select YY as the stress Component.
     - Select Curve from the drop-down list. Click and the bottom symmetry axis of the plate.
     - Print the line plot and proceed to create the line plots for the other stresses.
A.3.8. Advanced Meshing

1. Refine Model > Sketch
   - Click on the plate displayed in the graphics window.
   - Click Sketch.
   - Click Center and Point and sketch a circle around the hole.
   - Click Delete Segment then select the unwanted segments of the circle in the graphics window to erase them.
   - Click Ok to complete the Sketch.

2. Refine Model > Surface Region
   - In the graphics window, click on region B
   - Click to complete the surface region.
3. Right click on Model Tree > AutoGEM Controls > AutoGEMControl1 and select Edit Definition.

- Click on region A.
- In the **Maximum Element Size Control** window increase **Element Size** to 11.

4. Refine Model > Control > Maximum Element Size

- Click on region B in the graphics window.
- In the **Maximum Element Size Control** window set **Element Size** to 4.

5. Refine Model > Control > Maximum Element Size

- In the **Maximum Element Size Control** window, select **Edges/Curves** from the drop down list for **References**.
- Click on the hole edge in the graphics window.

- In the **Maximum Element Size Control** window set **Element Size** to 3.

6. Refine Model > AutoGEM > AutoGEM

- In the **AutoGEM** window select **Surface** from the drop-down list.
• Click and select both regions A and B of the plate with hole.
• In the AutoGEM window click Create.
• Close appearing message windows and when asked save the mesh.

A graded mesh created with Advanced Meshing.

B. Howland expressions for stress concentration factors

Howland derived semi-analytical expressions for the stress concentration factors at the edge of a symmetric hole of radius $R$ in a plate of finite width $2W$. These factors have been calculated for a range of plate geometries and are shown in the table below.

<table>
<thead>
<tr>
<th>$R/W$</th>
<th>Point A</th>
<th>Point B</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>$\sigma_{xx}/\sigma_0$</td>
<td>$\sigma_{yy}/\sigma_0$</td>
</tr>
<tr>
<td>0</td>
<td>3.00</td>
<td>-1.00</td>
</tr>
<tr>
<td>0.1</td>
<td>3.03</td>
<td>-1.03</td>
</tr>
<tr>
<td>0.2</td>
<td>3.14</td>
<td>-1.11</td>
</tr>
<tr>
<td>0.3</td>
<td>3.36</td>
<td>-1.26</td>
</tr>
<tr>
<td>0.4</td>
<td>3.74</td>
<td>-1.44</td>
</tr>
<tr>
<td>0.5</td>
<td>4.32</td>
<td>-1.58</td>
</tr>
</tbody>
</table>